How to troubleshoot a "No Device Found" error when attempting to pair your MEATER Block.
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About This Device | MEATER Block Support Guide |
Pairing Instructions | Pairing a MEATER Block |
MEATER Block Firmware |
Finding MEATER Block Firmware Version |
Firmware Updates |
Symptoms
The error, "No Device Found," as shown in the image below, may appear on your mobile device when using the MEATER app's Quick Startup Guide to pair your MEATER Block with the MEATER app.
Common Causes
A "No Device Found" error may appear for several reasons:
- The MEATER BLOCK does not show "Open App + Add BLOCK" on the screen
- Your smart device doesn't have Bluetooth enabled.
- There is a communication issue with your smart device, and it needs to be rebooted.
- If you're using an Android device, Developer Mode is enabled.
How to Resolve This Issue
1. Does, "Open App + BLOCK", appear on the MEATER Block Screen?
Before attempting to pair your Block with the MEATER app, the Block screen should display the text, "Open App + BLOCK."
If the MEATER Block displays this, proceed to the next step to check your Bluetooth settings.
If the MEATER Block does NOT display this message, continue below:
- Reboot the MEATER Block by powering the device off and turning it on again.
- Select Use Wifi Mode.
- The next screen should display, Open App + Block.
If the Block still doesn't display Open App + BLOCK, continue:
- Check the MEATER Block's firmware.
- Firmware 2.0.4.25 and higher:
- Reboot the MEATER Block again, selecting Use WiFi Mode, and see if Open App + Block displays.
- If not, tap the settings cog button on the touchpad (to the left of the power button).
- Use the up/down arrows on the touchpad to scroll until you find the Setup WiFi option.
- The Setup WiFi option is available only on firmware versions 2.0.4.25 and higher.
- Firmware 2.03.94:
- Reboot the MEATER Block again, selecting Use WiFi Mode, and see if Open App + Block displays.
- If not, press and hold the settings cog button on the touchpad (to the left of the power button). The screen will display a screen saying, Erase all settings?
- Use the down arrow to select Yes, and tap the center circle button to confirm. Selecting Yes restores the MEATER Block back to its factory default settings.
- The Block will guide you to power off the MEATER Block, charge the probes, and set your preferred temperature units.
- Turn the Block back on, select Use Wifi Mode, and the screen should display Open App + Block.
- Pair the device with the MEATER app, following the prompts.
2. Check Smart Device Settings
The MEATER App is supported by the following OS versions. Verify your device's operating system before continuing to ensure compatibility.
- Android 8.0 and above
- iOS 14 and above
Once confirmed, make sure your smart device’s Bluetooth is enabled. If Bluetooth is turned off, turn it on and try pairing again.
Android Only: If Bluetooth is enabled and the No Device Found error continues, check if your device is in Developer Mode. Many Android users encounter issues when Developer Mode is enabled. Turning it off can resolve connectivity and pairing issues.
- Check if the Android is in Developer Mode. If it is, disable it and reboot your device.
- If you're using this device to communicate with MEATER Support, rebooting will disconnect you. Be sure to follow the remaining instructions independently so you don’t need to reconnect unless needed.
- Once your device has rebooted, reopen the MEATER App and confirm that the MEATER Block is on